WELCOME TO RIVER DAVES PLACE

496 back fire cuts outs.

Lavey 29

Well-Known Member
Joined
May 14, 2016
Messages
184
Reaction score
79
the fuel pressure is 43 for these plus or minus 2 psi. using a quality gauge. Whats your engine serial number ? and whats your latest issues ? I really do not have time to read thru all these posts to see whats going on, sorry about that.

A little info about the MERCRUISER IAC for all the 555 pcms and ecms unless you have DTS - DTS USES NO IAC period fyi info for whomever - anyways the IAC can be tested using the scan tool and montoring the PWM % s. Thats one way to tell if the IAC is going bad or is bad. THE IAC alot of times does not throw a fault code when its going bad or is bad.

Have you ran the engine on a remote gas tank with new gas and new gas line ?
 

H8Plow

Member
Joined
Dec 30, 2020
Messages
17
Reaction score
18
Oh and i put a new tps in it today and she got alll pissed off and wouldn't get on plane and started beeping at me. So i put the old one back on and she went back to normal. Is there a special way u have to to replace those??
When replacing the tps switch, it should have two mounting holes that are elongated. This is a very fine adjustment, you are looking to achieve .5v at closed throttle and above 4v at wot (ideally the wot voltage should be close to 4.5v.
 

02HoWaRd26

Well-Known Member
Joined
Dec 19, 2007
Messages
6,830
Reaction score
12,695
Well boys................. WE DID IT!!!!!!!!!! SHE RUNS PERFECT THANKS TO ALL INPUT.
Was the faulty low pressure pump or???? Come on, you gotta finalize those thread with what exactly the solution was.
The guy who finds this two years from now while diagnosing his similar issue will greatly appreciate the closure as well. lol
 

tbults88

Well-Known Member
Joined
Nov 30, 2020
Messages
56
Reaction score
55
When i get to sit down tonight ill right. A start to finish report. I believe it was a number of things
 

tbults88

Well-Known Member
Joined
Nov 30, 2020
Messages
56
Reaction score
55
Ok. Start to finish.
Test drive 1
Boat fired up and idled. After 4-5 min boat would die. Found water in the fuel tank.
We drained the tank had it coated replaced low pressure fuel pump lines and fuel filters.
Test drive 2
Boat fired up idled great but fell on its face with when giving it throttle. Replaced high pressure fuel pump and fuel pressure regulator on cool fuel system. Under the port side motor mount.( dm me for info on that if you need help i did it with out pulling the engine.)
Test drive 3
Noticed surge in the idle and whooshing sound threw intake at idle. Boat got on plane and would run at half throttle. Then fall on its face and back fire if given more than half throttle. We replaced IAC and map censor and hooked up fuel pressure gauge and replaced anti syphon valve in fuel tank
Test drive 4
Whooshing sound gone and idle is steady. Boat got on plane and could run full throttle for short period of time. Fuel pressure dropped at top end from 40psi to 10psi. Boat would fall on its face.
Shut the boat down and unplugged low pressure pump. Turned key on and heard high pressure pump prime engine. Plugged low pressure side back in and un plugged high pressure side turned key and low pressure pump was not turning on. (The one i replaced in the begining.) Verified voltage from ecu to low pressure pump with voltage meter Replaced that pump and fuel filters again.
Test drive 4
Boat ran GREAT WIDE OPEN THROTTLE!!!!!!!!!!
then.................boat started sputtering idled great but would spit and sputter when giving it throttle. Alarm was going off. Replaced TPS alarm gone boat ran GREAT. I believe there was a small list of probs due to this boat sitting for 3 years before i bought it. Both pumps had to be replaced the IAC fixed the idle surge and whooshing threw intake. The map sencor let it get to full throttle for short periods of time. TPS fixed alarm and sputtering in the end. If you are dealing with any issues like this feel free to dm me and i will share what i learned threw this experience from @shelbynitro i hope this threads helps guys in the future. Thank you again for all the input guys.
 

Yoshiro

Active Member
Joined
Jan 15, 2021
Messages
37
Reaction score
111
Wow that was a lot of stuff to diagnose and replace. You earned this one!
 

sintax

Well-Known Member
Joined
Mar 7, 2008
Messages
3,219
Reaction score
3,824
good work on everyone getting that sorted out. Way more complex than I expected it to be going into it :)
 

billperkins3@att.net

Well-Known Member
Joined
May 6, 2016
Messages
1,792
Reaction score
1,859
Ok ill start from the beginning. Im at a loss. Bought a 2003 24 aftershock got a good deal at 15k has 496 mag with bravo one. Took the boat out fired it up and it would idle for 5 min then die. Found water in the fuel. Took the boat home drained the tank had it cleaned by gretchens in LB they also replaced the low pressure pump and had the injectors cleaned. Next trip idles great starts to get on plain then falls on its face. Took it home replaced filters again put in new high preasure pump and fuel pressure regulator ( the one under the motor mount the cool fuel system. That was a nightmare) then took it out today. Idle great got on plane did about 30mph. Opened it up and back fire miss backbfire bring it down to idle runs great. Shut it down for 20 min fire it back up Start to get on it ran all the way around lake elsinore at 30mph no problems open it up and pop pop miss back fire. Any one had a problem like this?
Saweet results.... told ya this site rocks..... I'm taking credit for hooking ya up with Mr PHD, @shelbynitro .... cheers!
 
Top