WELCOME TO RIVER DAVES PLACE

Flo-Torq II HD Hub question

zx14

Well-Known Member
Joined
May 4, 2010
Messages
2,149
Reaction score
2,419
Maybe stupid question, I never thought much about prop hubs, other than the plastic strips fall off, they just work.
Went to change props last night, and the prop came off but hub stuck, not really uncommon, but this time I pull the HB off and the plastic insert that rides on the smooth part of the shaft is sticking out of the hub about 3/8 of a inch, and is chewed up. It was riding inside the red aluminum ring that houses the seal on the imco lower. The seal doesn’t appear to be damaged,(no oil leaking out). The plastic insert from the hub doesn’t really fit in there, thus a bit chewed.
So my question is, why did it move out? My insert as you can see in the pics, comes out with a couple taps from a screw driver.
Are they usually in there real tight? Since I have never removed it, I don’t know.
Should I just put it back in and run it? I don’t know what pushed it out in the first place so afraid it could waste the propshaft seal allow water intrusion, thus fucking up my new SCX and rebuilt lower.(has like 25 hours on it)
Haven’t bought a hub in forever , damn things are $140. Not a big deal if I need one, but don’t want to buy one if 1, you can buy just the insert , or 2 get a new one , and you can tap the inserts out like I did here and I have not really solved anything.
I have ran Thai setup over 100mph many many times, check drive oil a lot, so have removed prop every couple of trips, have never seen this.
089250B3-850B-4443-9A68-7DEE835FE97D.jpeg
E4C0360E-E9A5-4325-9312-349B8F4FAA00.jpeg
 

ONE-A-DAY

Well-Known Member
Joined
May 21, 2010
Messages
13,343
Reaction score
12,767
Interesting, for $100 or so I wouldnt try to repair it, just buy another or I have a couple in my drawer if you need one now that i run solid hub props
 

zx14

Well-Known Member
Joined
May 4, 2010
Messages
2,149
Reaction score
2,419
Interesting, for $100 or so I wouldnt try to repair it, just buy another or I have a couple in my drawer if you need one now that i run solid hub props
I would like to take you up on borrowing one today,
 

Ragged Edge

Well-Known Member
Joined
May 4, 2011
Messages
1,265
Reaction score
1,089
My best guess is that the hub insert is wearing out. I would suggest calling Kyle at WOT Marine 760-804-2766 on Monday and asking about it. They also have the new hub at competitive prices.
 

zx14

Well-Known Member
Joined
May 4, 2010
Messages
2,149
Reaction score
2,419
My best guess is that the hub insert is wearing out. I would suggest calling Kyle at WOT Marine 760-804-2766 on Monday and asking about it. They also have the new hub at competitive prices.
I’m thinking the same thing, just need a new one, my buddy who long ago worked for mercury racing says they recommend a new one e
 

zx14

Well-Known Member
Joined
May 4, 2010
Messages
2,149
Reaction score
2,419
Thanks to n2otoofast4u for letting me borrow an extra, until my new one shows up.
FYI, these things ware out. I can totally feel how snug this one fits the prop shaft compared to my old one.
 

02HoWaRd26

Well-Known Member
Joined
Dec 19, 2007
Messages
5,228
Reaction score
8,263
Thanks to n2otoofast4u for letting me borrow an extra, until my new one shows up.
FYI, these things ware out. I can totally feel how snug this one fits the prop shaft compared to my old one.
All them holes wear out after enough passes .......
 

zx14

Well-Known Member
Joined
May 4, 2010
Messages
2,149
Reaction score
2,419
I got the new one today, and I would say they had a problem with this, and now have a ,”C” clip in there to hold in that sleeve
E4871A3A-968E-4D3D-9445-E27628D6A4BF.jpeg
 

Motoxxxloak

Well-Known Member
Joined
Aug 26, 2014
Messages
2,025
Reaction score
1,320
image-2020-04-22-15:29:33-077.jpg

Are the rubber pieces necessary? What is the purpose of them?


Sent from my iPhone using Tapatalk
 

zx14

Well-Known Member
Joined
May 4, 2010
Messages
2,149
Reaction score
2,419
Just hold them or I use silicon and glue um back on
 
Top