WELCOME TO RIVER DAVES PLACE

Need RDP braintrust knowledge

Brennan

Well-Known Member
Joined
Feb 2, 2018
Messages
119
Reaction score
187
First off happy Fathers Day to all the dads out there

So need some advice on where to start on fixing an error code I’m getting on my Mercury 525 with roughly 260 hours

I launched at katherines landing on Friday ran the boat twice before lunch for approximately 15 minutes each time. Boat ran great all gauges looked good. Found a beach and hung out all day until about 3:30. Tried to start the boat and as soon as I turn the ignition key to power I hear three beeps which I never have heard before. I proceed to try and turn it over anyway to see if I can at least limp it to the marina. Will crank all day but won’t turn over. I’m confident because it is in guardian mode. So I get a tow (crushing my ego) back to the marina and put it on the trailer. I call Kevin at Iguana Marine and he was super cool said shop closes at 5 but he will stay late for me. So I haul ass down to havasu get there at 6 and the second I turn the key on, no more alarm. So I tell him I’m confident the boat will start. Sure enough, fires right up no problem. Initially he thinks maybe my fuel filter is starting to go out due to how loud it is, but fuel filter and pressure are full and tons of pressure. Fuel pressure gauge reads at 45 which is normal.
I decide to take the risk and run the boat again the following day. In fact I run it from katherines all the way to cottonwood cove at about 70mph average speed. Gauges look great. Engine temp never got over 150. Ran it back down after an hour break up there. Park at the same beach as day before and start to float and hangout. About an hour and a half later I jump in the boat to see if it gives the same alarm and sure as shit it beeps three times again. This time I don’t even try to start it. I decided to wait it out, lifted my engine hatch blower on even though I don’t believe it’s an engine temp issue. To keep my wife quiet I even threw a cold towel over the motor, an hour later still no luck still have the safety beep. Half hour later I turned the key and alarm was gone. I started the motor and did about 80+ back to the dock and onto the trailer. At the marina I turned it off and back on with no issues. I’m thinking a bad sensor? Any suggestions???

Only other odd things I noticed was that my water pressure gauge never came off zero. I’m under the understanding that at idle it should stay at close to zero but under power should rise up. Never came off 0 despite rpms or speed.

second thing is whenever the bot was in the alarm mode the trim gauge would not work. Trim would work but needle would not move at all. Before and after alarm started huge worked again.

anyone know where to start???
thanks
 

Runs2rch

Well-Known Member
Joined
Jun 10, 2013
Messages
8,561
Reaction score
7,671
Crank no start leads to either crank or cam sensor. Possibly TPS. All other sensors would still let it run, not all 3 beep alarms will run in guardian mode either.
 

ONE-A-DAY

Well-Known Member
Joined
May 21, 2010
Messages
17,969
Reaction score
25,022
There’s something like 60 sensors on a 525 I heard, usually the issue is the sensor not the engine. And the beeps can mean different things, some of the beep sequences list about 10 possible issues. It’s even worse with twins cause you don’t know which one is beeping.
 

Runs2rch

Well-Known Member
Joined
Jun 10, 2013
Messages
8,561
Reaction score
7,671
There’s something like 60 sensors on a 525 I heard, usually the issue is the sensor not the engine. And the beeps can mean different things, some of the beep sequences list about 10 possible issues. It’s even worse with twins cause you don’t know which one is beeping.
Hahaha. Def not 60 sensors.
 

LHC Kirby

LifeTime Member
Joined
Jan 12, 2008
Messages
2,844
Reaction score
3,803
When you go out a second time and expect the same problem. Video the event, best case it is now on video... worst case, the boat starts. I’m thinking it’s a sensor...

Good luck, let us know what you find out.
 
Last edited:

Rotten deal

Well-Known Member
Joined
Feb 26, 2016
Messages
1,000
Reaction score
1,255
Wouldnt scanning the motor be a start? It will show the event and at what hour it happened if it threw a code. Doesn't always give you exact cause but leads in right direction.
 
Top